Search…

X3 Photo Gallery Support Forums

Search…
 
User avatar
mjau-mjau
X3 Wizard
Topic Author
Posts: 11998
Joined: 30 Sep 2006, 03:37

Files APP first release!

24 Feb 2020, 05:49

First version of our Files app was released today! See official announcement.

Files App
Files is a fast-loading single-file PHP app that can be dropped into any dir on server, instantly creating a gallery of files and folders. It supports all file types and allows you to preview images, video, audio and code. You can search and sort files in real-time and toggle gallery/list layouts.

Website
files.photo.gallery

Demo
https://files.photo.gallery/demo/
Image

Features
  • Single file. Simply drop it into any directory on server!
  • Search and sort files in real-time.
  • Advanced list and gallery layouts that can be toggled in real-time.
  • Preview IPTC, EXIF and GPS maps for your photos.
  • Fast loading using cache mechanisms and CDN.
  • Advanced tree-menu navigation displays entire directory structure.
  • Beautiful code highlighter to view and edit code formats.
  • Optional login to protect access.
  • FUTURE FEATURES: File-management (upload, move, copy, delete, zip, unzip), IPTC editor, panorama viewer, multi-user login, batch-resize images, image editor (crop,resize, rotate), automatic multi-language, video-thumbnails, favorites folder, watermarking tool and much more. The ultimate Swiss army-knife file tool/viewer/manager  :smile:
More Demo's Download
Please visit files.photo.gallery to download the Files app.

Subscribe
Please sign up for the Newsletter to get Files App updates.

Feedback is welcome! :star:
 
povvy
Posts: 7
Joined: 21 Jan 2020, 07:54

Re: Files APP first release!

02 Mar 2020, 11:22

Looks great!! Simply love the look of the images thumbnails with rounded squares... is it possible to reproduce it on a gallery on X3?
 
User avatar
mjau-mjau
X3 Wizard
Topic Author
Posts: 11998
Joined: 30 Sep 2006, 03:37

Re: Files APP first release!

03 Mar 2020, 03:39

povvy wrote:Looks great!! Simply love the look of the images thumbnails with rounded squares... is it possible to reproduce it on a gallery on X3?
Thanks for feedback. Indeed some of the ideas here will be ported into future releases of X3. As for rounded corners, that would be easy to add into current X3 websites using some basic custom CSS. To add rounded corners globally to all images, regardless of layout, add the following to Settings > Custom > Custom CSS:
Code
.image-container {
  border-radius: 3px;
  overflow: hidden;
}
If you want to set on a per-gallery basis, or only for certain gallery layouts, you will need some further adjustments.
 
povvy
Posts: 7
Joined: 21 Jan 2020, 07:54

Re: Files APP first release!

03 Mar 2020, 10:30

Great, thanks, i'll try implementing it.
Glad to know you will port some of the ideas here in the future versions
 
User avatar
andreamarucci
Experienced
Posts: 298
Joined: 01 Mar 2011, 11:13

Re: Files APP first release!

04 Mar 2020, 17:19

Awesome as usual. Thank you very much!!!
 
chef.li
Posts: 2
Joined: Yesterday, 16:51

Re: Files APP first release!

Today, 05:59

I was very pleased to read the message about the new Files app. I have been using a similar single-file PHP app for a long time but it hasn't been maintained for 10 years.
I just tried to create a test page with the new app. Unfortunately I have some problems with the menu navigation. The submenus of all main menus can be seen under the last main entry. I think this happens because some subdirectories have the same name.
Also the whole menu tree disappears as soon as a directory name contains a special character (in this case the "ü" of Zurich).
Image  Image 

I used the Files app unchanged (PHP version 7.1.1 on the server, the extensions GD and mbstring are enabled) 
 
User avatar
mjau-mjau
X3 Wizard
Topic Author
Posts: 11998
Joined: 30 Sep 2006, 03:37

Re: Files APP first release!

Today, 06:23

chef.li wrote:I just tried to create a test page with the new app. Unfortunately I have some problems with the menu navigation. The submenus of all main menus can be seen under the last main entry. I think this happens because some subdirectories have the same name.
Hmmm interesting ... You mean it's duplicating all dirs into the last dir in the menu? Would be great to be able to diagnose this. Do you have a public link for me, or is it on your local server?  
chef.li wrote:Also the whole menu tree disappears as soon as a directory name contains a special character (in this case the "ü" of Zurich).
Strange. We have folders in all languages in our demo, including "heizölrückstoßabdämpfung":
https://files.photo.gallery/demo/?tests ... C%88mpfung

Appreciate the feedback!
 
chef.li
Posts: 2
Joined: Yesterday, 16:51

Re: Files APP first release!

Today, 07:07

The described behaviour can be seen at https://test.chef.li/.
Subdirectories are only visible under the last item in the menu, but under all other entries I can see the subdirectories and the images also.
The directory structure on the server corresponds to the first image in the previous post.
 
User avatar
mjau-mjau
X3 Wizard
Topic Author
Posts: 11998
Joined: 30 Sep 2006, 03:37

Re: Files APP first release!

Today, 10:29

chef.li wrote: The described behaviour can be seen at https://test.chef.li/.
Subdirectories are only visible under the last item in the menu, but under all other entries I can see the subdirectories and the images also.
The directory structure on the server corresponds to the first image in the previous post.
Thanks. I can already see the problem ... The server (PHP) is actually returning the folders correctly, but it's getting messed up in the javascript that creates the menu. The reason is that I (perhaps naively) expected folders to be returned in a specific linux-default order, with sub-directories immediately following their parent. However, on your server, it first lists all the root dirs, and then starts subdirs AFTER all root dirs are listed.

This messes up the javascript that creates the menu. Clearly this has to be fixed, so I will look into it tomorrow. Out of interest, may I ask what server this is? Maybe Windows+Apache?

About the ü issue, I can't reproduce from here, and would need to diagnose somehow.