Search…

X3 Photo Gallery Support Forums

Search…
 
manupadillaph
Topic Author
Posts: 6
Joined: 27 Jun 2018, 15:10

Error http 500 while trying to access the panel

27 Jan 2019, 12:31

Hello friends!

This is my website
http://www.manuelpadilla.com.ar


I was using X3 for a while without problems
I updated to the last version and now I cant enter in the control panel anymore.
I was researching and I read about the Mcrypt, that I think in the server is not installed and I cant install it.
But after I read that new versions of X3 are using another thing (openssl or something like that)

Anyways I also tried to USE_DB feature for the Panel. 
I created the database and used the Panel/Install scrip without problems.
But anyways when I try to enter http://www.manuelpadilla.com.ar/panel/ I still have the same issue.

You can see Diagnostic here and here

Could some one point me something here?
It will be very much appreciated.

Thank you!!! 
 
User avatar
mjau-mjau
X3 Wizard
Posts: 12880
Joined: 30 Sep 2006, 03:37

Re: Error http 500 while trying to access the panel

27 Jan 2019, 21:16

Hi Manuel.

I checked your website your website and can confirm there is a HTTP ERROR 500 when trying to access the /panel/. I don't think this is related to mcrypt or database vs non-database. In both cases, you should still get the login page at least.

I do see your hosting has very old PHP version 5.3 (more than 10 years old). I would recommend logging in to your hosting account and check if you can change the PHP VERSION (preferably to PHP 7.x if possible). This should be an option from all hosting services. If it's not an option, you should contact your host and ask them to upgrade the PHP version.

After upgrading PHP, the issue might already be solved. If not, I may need FTP login details to find out why the panel returns error. It could be server config / htaccess / firewall related also. I am guessing that updating PHP has a fair chance of solving the issue.
 
manupadillaph
Topic Author
Posts: 6
Joined: 27 Jun 2018, 15:10

Re: Error http 500 while trying to access the panel

28 Jan 2019, 00:37

Hello!!!
Thank you so much for you quick answer.
Was is interesting is that I had X3 working before.
I just updated to the latest and this began happening.
I tried to downgrade to the oldest version that is still available in the website but nothing changed.
I can't upgrade PHP on the server :(
Ill send credentials for ftp by private message!
Thank you again!!!!
 
User avatar
mjau-mjau
X3 Wizard
Posts: 12880
Joined: 30 Sep 2006, 03:37

Re: Error http 500 while trying to access the panel

28 Jan 2019, 03:46

Ok I have fixed the Error http 500. There was a line of code incompatible with the old PHP 5.3. I failed to login to the panel though ... could be missing encryption extension. Try DB login?
manupadillaph wrote:I can't upgrade PHP on the server :disappointed:
You really need to ask questions about this. PHP 5.3 was released in 2009 and is slow, insecure and outdated. I really don't know any professional host who will not allow newer PHP, for their own security and their clients. I noticed they had even disabled phpinfo() function for security reasons, but then why not allow new secure PHP versions. In my opinion, totally unacceptable and this hosting is not professional.
 
manupadillaph
Topic Author
Posts: 6
Joined: 27 Jun 2018, 15:10

Re: Error http 500 while trying to access the panel

28 Jan 2019, 06:49

Ohh thank you sir!

It is working  now, buuuuuuuuuuuuut:

1. when I enter into panel/users nothing is show... I dont remenber what is suppose to appear there.
2. others option in panel work all right, but when i enter into any panel/content everything is becoming slow. 
Pages takes several seconds to open. The rest of the options in Panel works fine. I moremore dont know if this is a related issue. But in the old x3 version I had before times were more normal.

I send credentials for admin by private.

And thanks again!!!!!!
 
manupadillaph
Topic Author
Posts: 6
Joined: 27 Jun 2018, 15:10

Re: Error http 500 while trying to access the panel

28 Jan 2019, 06:56

And last one thing!! 
Contact is not working also :(
It is related to the php version also I believe!
Sorry for all this inconveniences.

Maybe you can have any workaround to get this working again?

I got this message in developers console:

jquery.min.js:2 [Deprecation] The deviceorientation event is deprecated on insecure origins, and support will be removed in the future. You should consider switching your application to a secure origin, such as HTTPS. See https://goo.gl/rStTGz for more details.
add @ jquery.min.js:2
x3.min.js:3 X3 / PHPMailer debug
------------------
<br />
<b>Parse error</b>:  syntax error, unexpected '[' in <b>/home/manuelpa/public_html/app/x3.api.php</b> on line <b>67</b><br />
 
User avatar
mjau-mjau
X3 Wizard
Posts: 12880
Joined: 30 Sep 2006, 03:37

Re: Error http 500 while trying to access the panel

28 Jan 2019, 09:18

manupadillaph wrote:1. when I enter into panel/users nothing is show... I dont remenber what is suppose to appear there.
"Users" should normally be empty, because it does not include the main ADMIN "super" user. It's only if you create additional users for others who are supposed to be able to edit your website. Your main super user is already available from your PROFILE section.
manupadillaph wrote:2. others option in panel work all right, but when i enter into any panel/content everything is becoming slow. 
Pages takes several seconds to open. The rest of the options in Panel works fine. I moremore dont know if this is a related issue. But in the old x3 version I had before times were more normal.
Well, what can I say? Your server is AWFUL. It's not related to X3 because it's even having problems loading an image by direct link:
Image

Had to try 10 times before I could connect by FTP:
Image

Fails to contact the script for the contact form:
Image

Pages are down half the time:
Image
Image

If you want to sort this out, you need to sort out your server and hosting. Who is the hosting company anyway? How much are you paying? It's not professional. If you want, I can offer to host your website on our dedicated X3 hosting www.flamepix.com for SAME PRICE as you pay your current hosting. If not, you need to sort out your hosting or look for another hosting.

This is not related to latest X3 version.
manupadillaph wrote:And last one thing!! 
Contact is not working also :(
It is related to the php version also I believe!
Sorry for all this inconveniences.

Maybe you can have any workaround to get this working again?
I logged in and fixed a few lines of code for backwards PHP 5.3 compatibility. However, I cannot current test the contact form because nothing on your website is loading https://d.pr/i/93CRCl. Not even plain images https://d.pr/i/SLCVcs.
manupadillaph wrote:jquery.min.js:2 [Deprecation] The deviceorientation event is deprecated on insecure origins, and support will be removed in the future. You should consider switching your application to a secure origin, such as HTTPS. See https://goo.gl/rStTGz for more details.
add @ jquery.min.js:2
Unrelated. It just states Google Chrome does not support mobile "deviceorientation" as long as your website is not on HTTPS/SSL, but this is only a feature for the panorama plugin.
manupadillaph wrote:x3.min.js:3 X3 / PHPMailer debug
------------------
<br />
<b>Parse error</b>:  syntax error, unexpected '[' in <b>/home/manuelpa/public_html/app/x3.api.php</b> on line <b>67</b><br />
I believe this has been fixed, but I cannot access anything on your website.
 
User avatar
mjau-mjau
X3 Wizard
Posts: 12880
Joined: 30 Sep 2006, 03:37

Re: Error http 500 while trying to access the panel

28 Jan 2019, 10:10

Tested your website and the contact form seems to work now after a few edits for PHP 5.3:
Image
 
manupadillaph
Topic Author
Posts: 6
Joined: 27 Jun 2018, 15:10

Re: Error http 500 while trying to access the panel

30 Jan 2019, 04:41

Thank you!!!! 
Amazing support. 
Ill try to change the PHP in the server anyways. 
I let you know if I need your hosting!
Thankss!