Search…

X3 Photo Gallery Support Forums

Search…
 
User avatar
DeerSpotter
Topic Author
Posts: 13
Joined: 30 Mar 2011, 22:15

Index page not working properly

08 Apr 2015, 11:08

My index page, i can't seem to restore it back to default anymore, or at least load a slideshow up. http://www.sandboxreviews.com
Code
# INDEX [HOME PAGE]
# The folder "1.index" is reserved for your homepage (startpage), and should therefore not be deleted. You cannot add other folders inside the '1.index' folder, because it is simply reserved as a placeholder for the Home page (add your folders from the root 'Content' folder instead).

# EXAMPLE
# In this example, we are using several advanced settings to achieve re-ordering of the content and gallery. This will be explained in different examples.

title 		: Greetings SB Reviewer!
label		: Home
description	: All The Reviews in one Place, Anytime, Anywhere!
date		: 
image		: 
menu		: 
body		: menu-absolute-20 no-pad
layout		: items:gallery,context,folders
context		: separator
folders		: grid:3,2,1 assets:galleries items:title,preview caption:description,amount crop:3,2 caption-bottom caption-hover frame text-center title-small
gallery		: wide assets:galleries/landscapes slideshow autoplay loop
content		: |
 
User avatar
mjau-mjau
X3 Wizard
Posts: 12634
Joined: 30 Sep 2006, 03:37

Re: Index page not working properly

08 Apr 2015, 13:42

You deleted or renamed the gallery/landscapes/ folder I assume?
Code
assets:galleries/landscapes
If you are using the "assets" setting above, to load images from a different folder, you will need to make sure you set it to a folder that exists and has images.
 
User avatar
DeerSpotter
Topic Author
Posts: 13
Joined: 30 Mar 2011, 22:15

Re: Index page not working properly

08 Apr 2015, 14:19

Thank you!
 
User avatar
mjau-mjau
X3 Wizard
Posts: 12634
Joined: 30 Sep 2006, 03:37

Re: Index page not working properly

09 Apr 2015, 03:27

Keep in mind, you don't need to use the assets setting ... You can upload images directly to the folder instead! The assets setting is only if you need to load images for another folder for some reason, like we are doing for practical reasons in our demo folders.
 
User avatar
GGANG
Experienced
Posts: 121
Joined: 02 Feb 2012, 11:01

Re: Index page not working properly

01 Jul 2015, 16:33

Hi Karl,
I have 2 main folders named wedding and pre-wedding want to show on the home page both of them.
Is it possible?
Code
folders		: wide columns:3,20,r shuffle assets:pre-wedding
 
User avatar
mjau-mjau
X3 Wizard
Posts: 12634
Joined: 30 Sep 2006, 03:37

Re: Index page not working properly

02 Jul 2015, 04:45

GGANG wrote:I have 2 main folders named wedding and pre-wedding want to show on the home page both of them.
Is it possible?
Unfortunately no. The "folders" module is meant to show content subfolders of the page. The "assets" setting allows you to choose a different folder to look for subfolders, instead of the page itself. Therefore, it is limited to a single page.

We may be able to extend this in the future, but for now it is limited.
 
User avatar
GGANG
Experienced
Posts: 121
Joined: 02 Feb 2012, 11:01

Re: Index page not working properly

02 Jul 2015, 05:53

mjau-mjau wrote:We may be able to extend this in the future, but for now it is limited.
Thank you very much. :D :D