Search…

X3 Photo Gallery Support Forums

Search…
 
User avatar
syna
Topic Author
Posts: 4
Joined: 14 May 2018, 04:51

Asian characters become question marks in IPTC

14 May 2018, 07:08

Hi,

I encountered a strange problem. If I set the Title of an image with Asian characters (including Chinese, Japanese, etc.), the gallery can function well. But when I download the image, then upload this image directly to an other folder, the Title shown in the panel becomes "????". I have noticed that the metadata in the downloaded image also becomes "????". 

I guess this problem is because of character encoding. Although it is good when I do not move these images, I want to know if anything I can do to fix it? Thank you.
 
User avatar
mjau-mjau
X3 Wizard
Posts: 11576
Joined: 30 Sep 2006, 03:37

Re: Asian characters become question marks in IPTC

14 May 2018, 10:13

Can you provide me a test image?

When you save title for an image, the data gets stored both in the page.json data file and inside the image (for portability). The data stored in page.json is likely correct, but it could be the data stored in the image does not get stored properly because of encoding issues.
 
User avatar
syna
Topic Author
Posts: 4
Joined: 14 May 2018, 04:51

Re: Asian characters become question marks in IPTC

14 May 2018, 22:26

It can be easily reproduced when I set Asian characters to any image. This is an example: https://skday.com/album/content/2.trave ... libili.jpg

I've checked "page.json", and it seems correct. 

In fact, all the images in this album (https://skday.com/album/travel/japan_2017/) have wrong IPTC titles. I agree that this is due to encoding issues when the data stored in the image.
 
User avatar
mjau-mjau
X3 Wizard
Posts: 11576
Joined: 30 Sep 2006, 03:37

Re: Asian characters become question marks in IPTC

15 May 2018, 00:13

I did some tests, and I can confirm this issue. It happens with non-latin characters, after moving or copying images to a new folder. It works before moving/copying, because the text is correctly stored in the page.json data file where the captions are originally created.

I will look into fixing this for next release, which should be in a few weeks.

In the meantime, your images with captions will not be "portable" (move/copy), unless you manually copy-paste data between page.json files or recreate captions after move.
 
User avatar
syna
Topic Author
Posts: 4
Joined: 14 May 2018, 04:51

Re: Asian characters become question marks in IPTC

15 May 2018, 07:44

Understand. Thank you!
 
User avatar
mjau-mjau
X3 Wizard
Posts: 11576
Joined: 30 Sep 2006, 03:37

Re: Asian characters become question marks in IPTC

19 May 2018, 01:52

I think this is fixed. If you have opportunity, please can you test for me:
  • Download updated iptc.php and replace panel/iptc.php in your X3.
  • Add an image title from the panel with unicode (eg Japanese). Save.
  • Copy the image to another directory. Is the title correct for the copied file?
 
User avatar
syna
Topic Author
Posts: 4
Joined: 14 May 2018, 04:51

Re: Asian characters become question marks in IPTC

19 May 2018, 02:18

Yes, it is fixed!

I've replaced the "iptc.php" file, and the title of the images are correct when I download and upload the images. 
Thanks very much for your work. 
 
User avatar
mjau-mjau
X3 Wizard
Posts: 11576
Joined: 30 Sep 2006, 03:37

Re: Asian characters become question marks in IPTC

18 Aug 2018, 04:14

This issue should now be resolved in version X3.25.0.
www.photo.gallery/blog/photo-gallery-X3-25/ | forum