Search…

X3 Photo Gallery Support Forums

Search…
 
User avatar
henning
Topic Author
Posts: 10
Joined: 10 Oct 2017, 22:20

Fresh install on "Dietpi" with raspi 5

06 Feb 2024, 03:10

Hi,
I'm trying to install X3 latest version on my new Raspi 5 with "Dietpi"  However the web installer does not work. I can start the script and on the 2nd page
it stops and complains about being not able to download the necessary files.
Image

in the log files I can find this : AH01071: Got error ‘Primary script unknown’
Any advise would be appreciated
Tks
PS when uploading all files direct to the website it starts only the diagnostic site and that screen stays there "forever"
 
User avatar
mjau-mjau
X3 Wizard
Posts: 13987
Joined: 30 Sep 2006, 03:37

Re: Fresh install on "Dietpi" with raspi 5

06 Feb 2024, 05:05

Honestly, this is so difficult to diagnose with a self-hosted, non-standard PHP server running on Raspberry Pi, that I can't even view from here.
henning wrote: Hi,
I'm trying to install X3 latest version on my new Raspi 5 with "Dietpi"  However the web installer does not work. I can start the script and on the 2nd page
it stops and complains about being not able to download the necessary files.
Well, it basically means PHP Curl failed on your server, without giving any specific reason. You would need to diagnose the curl function directly, it just doesn't work on your server.
henning wrote: in the log files I can find this : AH01071: Got error ‘Primary script unknown’
Any advise would be appreciated
Tks
Not something I can tell you, and I don't think it's even directly related to X3. Just search for this on google:
https://serverfault.com/questions/91422 ... pt-unknown
https://serverfault.com/questions/10269 ... -php-7-3-2
henning wrote:PS when uploading all files direct to the website it starts only the diagnostic site and that screen stays there "forever"
You might as well start by uploading files manually. If you need full functionality, you need to make sure your server is setup and capable of standard PHP functionality. I can't resolve that from here.

About the forever loading, you would need to check in developer tools and check any errors returned by javascript, but could easily be related to one of the same issues above.

I can't remote-diagnose a self-hosted Raspberry Pi installation any better unfortunately.
 
User avatar
henning
Topic Author
Posts: 10
Joined: 10 Oct 2017, 22:20

Re: Fresh install on "Dietpi" with raspi 5

06 Feb 2024, 07:12

Hi,

tks for yr reply. Not sure if that helps but the support guy tested X3 on one of his machines and it worked as planned. But he uses NGINX and not Apache. Test on Apache will follow. So let's see
 
User avatar
henning
Topic Author
Posts: 10
Joined: 10 Oct 2017, 22:20

Re: Fresh install on "Dietpi" with raspi 5

07 Feb 2024, 07:22

Hi,
small update on this issue : by manually downloading and copying files to the web-server I made it work. Only exception is the Diagnostic. That does not work at all. I saw a bit later that I can reach the panel and disabled it there. Now it's working
 
User avatar
mjau-mjau
X3 Wizard
Posts: 13987
Joined: 30 Sep 2006, 03:37

Re: Fresh install on "Dietpi" with raspi 5

07 Feb 2024, 23:35

henning wrote: by manually downloading and copying files to the web-server I made it work. Only exception is the Diagnostic.
Great, as long as it's working, you don't really need diagnostics ...
 
User avatar
henning
Topic Author
Posts: 10
Joined: 10 Oct 2017, 22:20

Re: Fresh install on "Dietpi" with raspi 5

18 Feb 2024, 09:09

Hi,
I was a bit ahead of things with my assumption that it is working. What is working is the head page with the background picture and the menu for the sub directories, But once I click on the relevant galleries it shows me this :

"Not Found

The requested URL was not found on this server."

The panel is working properly

If you have any clue on how to get it in working condition pls let me know
Tks
 
User avatar
mjau-mjau
X3 Wizard
Posts: 13987
Joined: 30 Sep 2006, 03:37

Re: Fresh install on "Dietpi" with raspi 5

18 Feb 2024, 21:31

This is related to rewrite, which are assigned in the .htaccess file (assuming this is Apache server?). So it looks like either the server does not support .htaccess or does not support mod_rewrite or it's not Apache. I can't see that from here. Check your page /?diagnostics.
 
User avatar
henning
Topic Author
Posts: 10
Joined: 10 Oct 2017, 22:20

Re: Fresh install on "Dietpi" with raspi 5

20 Feb 2024, 14:55

Hi,
tks for yr advise. 1. it's an Apache , 2. Diagnostics was saying at one stage "all OK" but when switching diagnostics off I just had a blank page and nothing else. On another attempt it should me a kind of animated ring probably some progress indicator, without progress.
I think I start from scratch on that machine. All data is safe.........
Tks
 
User avatar
henning
Topic Author
Posts: 10
Joined: 10 Oct 2017, 22:20

Re: Fresh install on "Dietpi" with raspi 5

23 Feb 2024, 03:42

Hi,

problem solved , it was indeed related to rewrite. An additional entry in the "etc/apache2/sites-enabled/@000-default.conf " solved it