Search…

X3 Photo Gallery Support Forums

Search…
 
ckishappy
Topic Author
Posts: 18
Joined: 21 May 2016, 06:07

Velocity UI Pack: You need to update Velocity (jquery.velocity.js) to a newer version. Visit http://github.com/juliansha

03 Jan 2022, 04:04

The Chromebrowser displays the following error message for my own website (polaschin.ch): "Velocity UI Pack: You need to update Velocity (jquery.velocity.js) to a newer version. Visit http://github.com/julianshapiro/velocity." What does it mean? Pls advise..
 
User avatar
mjau-mjau
X3 Wizard
Posts: 13146
Joined: 30 Sep 2006, 03:37

Re: Velocity UI Pack: You need to update Velocity (jquery.velocity.js) to a newer version. Visit http://github.com/julia

03 Jan 2022, 05:16

Well, it says that also, but you are getting many more errors before that which triggers a domino-effect of errors. This is not related to Velocity.
Image

It looks like you have a content-security-policy on your website, which is blocking requests to all scripts/CSS hosted on the CDN. This is assigned on your server, and it's not working properly or there are some problems in the syntax (as you can see in the screenshot above):
polaschin.ch wrote:content-security-policy: default-src 'self' 'none' https://*.amazonaws.com https://cdn.jsdelivr.com https://*.jsdeliver.com https://fonts.googleapis.com https://www.googletagmanager.com https://*.fontawesome.com https://www.google-analytics.com https://stats.g.doubleclick.net https://fonts.gstatic.com https://*.photo.gallery https://kit.fontawesome.com; connect-src https:; font-src https:; frame-src https:; img-src https:; media-src https:; object-src 'none'; script-src https://polaschin.ch https://*photo.gallery https://*jsdelivr.com 'unsafe-inline' 'unsafe-eval' https:; style-src 'unsafe-inline' https:;frame-ancestors 'self' https:;require-trusted-types-for 'script';base-uri 'none';
You need to resolve the above so that scripts/css can be loaded from CDN. Or just remove it. I don't really see much point in using content-security-policy ... If something gets loaded that is not supposed to load, it means someone has access to your website and it is already compromised.
 
ckishappy
Topic Author
Posts: 18
Joined: 21 May 2016, 06:07

Re: Velocity UI Pack: You need to update Velocity (jquery.velocity.js) to a newer version. Visit http://github.com/julia

03 Jan 2022, 08:13

:white_check_mark: OMG, this content-security-policy looks ugly, got it! Will fix it to make this horror show of errors going away & thanks! Chris