Search…

X3 Photo Gallery Support Forums

Search…
 
kmorwath
Topic Author
Posts: 8
Joined: 23 Jan 2020, 15:11

Menu links not update when modify the structure

21 Nov 2021, 17:40

Hello, I was moving some folders inside the menu structure - I moved some of them under the "Index" folder, using the menu "Move" command. Now the folders appears correctly in the Index page, the menu structure was updated, but the menu links were not, and now clicking them return a 404 error.
Attached an image the show the actual situation - the path highlighted in yellow is still the old one, now it should be under index.
x3_menu_links_issue.jpg
x3_menu_links_issue.jpg (27.12 KiB) Viewed 35 times
Did I made a mistake? How could I fix the links now? Is it correct all links now have a "home" icon?
 
User avatar
mjau-mjau
X3 Wizard
Posts: 13083
Joined: 30 Sep 2006, 03:37

Re: Menu links not update when modify the structure

21 Nov 2021, 23:29

Hi! The index page is actually your HOME PAGE (that's why it has the "home" icon next to it). It's not actually the ROOT of your website, as that is "Content". Where did you expect these subfolders to display? I am guessing you wanted them in the root of your website? In which case, they should be moved to "Content" not "Index", which is a special placeholder folder for your home page.

Hope this provides some clarity!
 
kmorwath
Topic Author
Posts: 8
Joined: 23 Jan 2020, 15:11

Re: Menu links not update when modify the structure

22 Nov 2021, 07:51

Thank you for your reply. They were previously under "Content", and they were accessible only through the menu, and the home page was just a static image. It was fine for me but some users didn't find it intuitive. Thus now I'm trying to show them as "folders" in the Home Page, below an image used as an intro (using the Page Intro plugin). Thereby I moved the folders as children of Index. It does work as expected, scrolling the home page folders appear below the intro image and folders have working links, but trying to access the same folders using the menu doesn't work. But maybe I need a different approach to put folders in the Home page - I'll try using the Advanced -> Folder Assets settings, I just thought it was easier to have them as children of the home page.

Edit: OK, I was able to obtain what I desired creating a "galleries" page, moving other pages as folders below it, and then using the Index page "Folder Assets" to get those displayed below the intro image. Not fully intuitive as it is an "Advanced" option, but still fully usable and fair.

Maybe the software should hinder moving pages under Index, if that is not supported. Also I noted that when moving page if the destination is not correctly selected first and them "Move" is pressed, then it's not always possible to continue without first closing the dialog and then reopening it. A minor issue, though.

Thank you!
 
User avatar
mjau-mjau
X3 Wizard
Posts: 13083
Joined: 30 Sep 2006, 03:37

Re: Menu links not update when modify the structure

22 Nov 2021, 09:19

Ok thanks for feedback! Glad you solved it.

The index as home page could probably be more intuitive, but we need to have one page which is basically "/" home page (basically no path), and one folder needs to be the "placeholder" for that page. It can't contain subfolders, because it's just a "placeholder", and all your root pages would need to be in the content root alongside index. If we allowed subfolders inside index, you would have urls like /index/gallery/. But yes, if you want to show subfolders from a different dir, you would use "assets" and that's is not easy to know up front!