Search…

X3 Photo Gallery Support Forums

Search…
 
eskimo121
Experienced
Topic Author
Posts: 104
Joined: 02 Jun 2012, 01:22

Download button does nothing on mobile

21 Nov 2018, 23:26

Hi, I didn't notice this before but a visitor to my site pointed out that the "Download" button does nothing when clicked on my site browsing on Mobile phone.
For example: visit this on your mobile using the latest chrome browser https://amazingpics.net/Nature/clouds/
Then touch any image and you can see the green "download" button show up on the bottom center of the image-----> Click and nothing happens. No image is downloaded on your mobile.
Any solution? thank you.
Thanks.


Bored? Browse through some cool images: Amazing Pictures
 
User avatar
mjau-mjau
X3 Wizard
Posts: 11337
Joined: 30 Sep 2006, 07:37

Re: Download button does nothing on mobile

22 Nov 2018, 03:13

Tested here on iPhone, and it definitely opens a new window with the image, where the user can choose to download the image. Did you try?

I cannot confirm that "nothing happens", although I can confirm on iPhone/iOS that the image does not download directly when download button is clicked, but that is a known device limitation. iOS (iPad/iPhone) does not support "download" like other devices, and therefore will fallback to opening the image in a new tab where the visitor has the option to share or "save to photos".
 
eskimo121
Experienced
Topic Author
Posts: 104
Joined: 02 Jun 2012, 01:22

Re: Download button does nothing on mobile

22 Nov 2018, 06:36

hmm strange, it seems to work now. I tried it in the landscape mode earlier and the button just turned black to indicate its been clicked on but nothing was being downloaded.  Sent a private message.
Thanks.


Bored? Browse through some cool images: Amazing Pictures
 
User avatar
mjau-mjau
X3 Wizard
Posts: 11337
Joined: 30 Sep 2006, 07:37

Re: Download button does nothing on mobile

22 Nov 2018, 06:48

Could be other problems on mobile if you used a different layout, I would have to test. Truth is, anchor links <a> embedded directly in the layouts are converted to <span>, because entire gallery item itself is an <a> link and we can't have <a> inside <a>. Links are always maintained as <a> in the popup mode.