Search…

X3 Photo Gallery Support Forums

Search…
 
Coolhand
Experienced
Topic Author
Posts: 29
Joined: 15 Apr 2018, 09:31

Problem with Sharing

17 Jul 2018, 19:34

Hello again,

I’ve noticed a problem with sharing pictures on social media platforms, I.e. Facebook.

 When I try to share this picture https://hobby-fotografie.mobi/Naturfoto ... d_meer-01/ it is not shown as preview on Facebook.

I thought it is a problem with the underscores, but the problem is the same with: https://hobby-fotografie.mobi/Sonstiges ... nd-das-03/.

There is no problem with some other pics, like: https://hobby-fotografie.mobi/Sonstiges ... nd-das-05/

Any ideas?

Mike
 
User avatar
mjau-mjau
X3 Wizard
Posts: 11412
Joined: 30 Sep 2006, 07:37

Re: Problem with Sharing

18 Jul 2018, 05:36

This seems to be a problem with Facebook, and empty spaces in your file names. The image is here:
sonne%20und%20meer-01.jpg

As you can see, empty spaces are replaced by %20. You can enter the url also with the spaces instead of %20, but technically, the browser encodes empty spaces as %20.
sonne und meer-01.jpg

Check Facebook's debugger for the page in your reference:
https://developers.facebook.com/tools/d ... meer-01%2F
Image

That image is clearly there, but Facebook doesn't like it. On a separate note, there is really no good reason to use empty spaces in image names. Image names should be short labels, and then you can use titles and description for extended information.

I see that we could possibly fix this in X3 by encoding empty spaces to %20 for the og:image sharing url designated for Facebook. I will try to add a fix for this in next release coming very soon.
 
Coolhand
Experienced
Topic Author
Posts: 29
Joined: 15 Apr 2018, 09:31

Re: Problem with Sharing

19 Jul 2018, 10:12

Again thx for the fast answer!

Implementing a solution in the next version is a very great idea!

Thx!!
 
User avatar
mjau-mjau
X3 Wizard
Posts: 11412
Joined: 30 Sep 2006, 07:37

Re: Problem with Sharing

18 Aug 2018, 08:12

Coolhand wrote:Implementing a solution in the next version is a very great idea!
This issue is now fixed in version X3.25.0.
www.photo.gallery/blog/photo-gallery-X3-25/ | forum