Search…

X3 Photo Gallery Support Forums

Search…
 
amateur56
Topic Author
Posts: 19
Joined: 12 Apr 2019, 04:31

Cant add new menu

03 Apr 2021, 07:34

Hi

Ive re-installed the gallery 3 times and get same answer.......
clean install...
Click "+New"
nothing happens, index menu is not there either but example etc are there but not on the left menu area and all show in site.
My other site works fine on same server?
see screen grab of manage page bellow (it used to work but not now? cleared cache etc also)
Image
 
User avatar
mjau-mjau
X3 Wizard
Posts: 12737
Joined: 30 Sep 2006, 03:37

Re: Cant add new menu

03 Apr 2021, 10:50

Either some server firewall mechanism or a missing file. I can check if you can give me link and login to your X3 panel.
 
amateur56
Topic Author
Posts: 19
Joined: 12 Apr 2019, 04:31

Re: Cant add new menu

03 Apr 2021, 11:00

PM'd you
 
User avatar
mjau-mjau
X3 Wizard
Posts: 12737
Joined: 30 Sep 2006, 03:37

Re: Cant add new menu

03 Apr 2021, 11:06

A firewall rule is blocking the menu from loading. See screenshot:
Image

If you load the same link in browser, it will display a white page and NOT create the error. This is because the firewall is only blocking POST requests. A very typical firewall response. Anyway, you need to either see if there are firewall options on your hosting control panel, or you would need to ask your hosting to disable firewall rules under the /panel/ folder.

If your other sites work fine, that would be because maybe they have the firewall disabled, or hosting disabled them ... or maybe they don't work now either. I can't really say, but this site for sure has a firewall rule blocking the menu from loading.
 
amateur56
Topic Author
Posts: 19
Joined: 12 Apr 2019, 04:31

Re: Cant add new menu

03 Apr 2021, 11:10

cool, I'll get in touch with host

thanks
George
 
amateur56
Topic Author
Posts: 19
Joined: 12 Apr 2019, 04:31

Re: Cant add new menu

03 Apr 2021, 12:05

fixed now great

He had to reconfiger the server somehow

Thanks