Search…

X3 Photo Gallery Support Forums

Search…
 
alderim
Experienced
Topic Author
Posts: 56
Joined: 27 Jun 2007, 09:49

Mail Form stuck in "sending"

06 Nov 2018, 13:22

Hi,
when i want to send a form
and the "send" button is hit it just stuck on the rolling "sending" animation.

thx for a hint!

http://www.5rhythmen-nuernberg.de/Seminar_Anmeldung/ 
 
User avatar
mjau-mjau
X3 Wizard
Posts: 11298
Joined: 30 Sep 2006, 07:37

Re: Mail Form stuck in "sending"

06 Nov 2018, 18:13

The X3 PHP script that sends the email has been deleted or blocked.
5rhythmen-nuernberg.de/app/x3.api.php
Image
 
alderim
Experienced
Topic Author
Posts: 56
Joined: 27 Jun 2007, 09:49

Re: Mail Form stuck in "sending"

07 Nov 2018, 10:42

thx for the tipp!
the file is already there
"blocked" means by the provider?
 
User avatar
mjau-mjau
X3 Wizard
Posts: 11298
Joined: 30 Sep 2006, 07:37

Re: Mail Form stuck in "sending"

07 Nov 2018, 10:55

alderim wrote:the file is already there
"blocked" means by the provider?
I cannot see if it is "not there" or "blocked", but as you can see, the file returns "file not found" when accessed:
5rhythmen-nuernberg.de/app/x3.api.php

From my experience, this is normally your HOST that has blocked access to the file. In which case, you need to contact them and ask why you cannot access it. As long as it is not accessible to X3, then how can X3 send mail? Likely part of your hosts security/firewall setup, but it's a poor implementation if they block access to some files without notifying you. This file needs to be accessible from the web, as it is part of the X3 application.