Search…

X3 Photo Gallery Support Forums

Search…
 
User avatar
GGANG
Experienced
Posts: 119
Joined: 02 Feb 2012, 16:01

Re: X3 Status Update [Aug 15]

19 Nov 2015, 00:01

@masquefotos
I can open each photos in "GALERIAS" by Chrome and Firefox on Windows 7.
All photos works fine. I can click the right arrow button to see the next photo as usual.
 
User avatar
mjau-mjau
X3 Wizard
Topic Author
Posts: 11337
Joined: 30 Sep 2006, 07:37

Re: X3 Status Update [Aug 15]

19 Nov 2015, 05:55

masquefotos wrote:I have a bug with Chrome on Windows and MacOS X, I put a video link
https://youtu.be/q92o7VkzjIg

once loaded Justified is closed and only gets to see updated
Thanks for sharing the video. The page goes blank after navigating to a page with justified layout? This only happens with justified layout?
 
User avatar
mjau-mjau
X3 Wizard
Topic Author
Posts: 11337
Joined: 30 Sep 2006, 07:37

Re: X3 Status Update [Aug 15]

19 Nov 2015, 05:57

tschortsch wrote:Right now I'm not able to show this div with custom css! Could you please give one more hint to get this working? :roll: I know there are many more important things for you to do right now!
If I get a link, I could perhaps debug with some custom CSS.
 
User avatar
masquefotos
Experienced
Posts: 140
Joined: 20 May 2011, 09:38

Re: X3 Status Update [Aug 15]

19 Nov 2015, 08:48

mjau-mjau wrote:
masquefotos wrote:I have a bug with Chrome on Windows and MacOS X, I put a video link
https://youtu.be/q92o7VkzjIg

once loaded Justified is closed and only gets to see updated
Thanks for sharing the video. The page goes blank after navigating to a page with justified layout? This only happens with justified layout?
I have only tried in justified which is what I like.
The photos normally charge and once caragada goes blank, I can only see them if I press F5 to change the folder and again beaten.
It happens on different computers but always with chrome
 
User avatar
mjau-mjau
X3 Wizard
Topic Author
Posts: 11337
Joined: 30 Sep 2006, 07:37

Re: X3 Status Update [Aug 15]

19 Nov 2015, 09:58

masquefotos wrote:The photos normally charge and once caragada goes blank, I can only see them if I press F5 to change the folder and again beaten. It happens on different computers but always with chrome
... and when did it start happening? Since X3 beta has been out for more than a year, this has not been reported by anyone, from any browser/OS at all. Seems a bit suspect, perhaps could be some browser-plugin, but we will keep an eye out ...
 
User avatar
Overmaster
Experienced
Posts: 51
Joined: 21 Jan 2011, 10:54

Re: X3 Status Update [Aug 15]

19 Nov 2015, 12:09

 
tschortsch
Experienced
Posts: 150
Joined: 01 Apr 2010, 21:23

Re: X3 Status Update [Aug 15]

19 Nov 2015, 12:13

mjau-mjau wrote:If I get a link, I could perhaps debug with some custom CSS.
Hi Karl,
I sent you the link to my X3 playground by PM, however I'm not quite sure if the message was actually delivered as it is still located in the outbox folder but received the message that it was successfully sent!
 
User avatar
mjau-mjau
X3 Wizard
Topic Author
Posts: 11337
Joined: 30 Sep 2006, 07:37

Re: X3 Status Update [Aug 15]

19 Nov 2015, 13:55

tschortsch wrote:Hi Karl,
I sent you the link to my X3 playground by PM, however I'm not quite sure if the message was actually delivered as it is still located in the outbox folder but received the message that it was successfully sent!
Did a quick fix for you.

Basically, you need to set NOT hide the context module, and instead apply CSS for absolute positioning (see your custom CSS). Then hide the title+description from context module, and set some custom CSS for the content within the context (see custom CSS). If you need more help with this, my time is limited, but please post in a separate thread.
 
User avatar
mjau-mjau
X3 Wizard
Topic Author
Posts: 11337
Joined: 30 Sep 2006, 07:37

Re: X3 Status Update [Aug 15]

19 Nov 2015, 13:58

Overmaster wrote:Galleries bug: https://youtu.be/exIBFTLl78U
Yes, I have seen screenshots already, and will be trying some more things. I may send you a few messages asking you to check on your side, because as mentioned, it always works from here ...
Overmaster wrote:Crop bug: https://youtu.be/iQAe90K5KFI
Not sure I understand what is going on in the video, or what you are trying to do. Please can you add crop to a page, and then send me the link to that page where you applied crop, where it is not working?
 
User avatar
Overmaster
Experienced
Posts: 51
Joined: 21 Jan 2011, 10:54

Re: X3 Status Update [Aug 15]

19 Nov 2015, 14:24

mjau-mjau wrote:
Overmaster wrote:Galleries bug: https://youtu.be/exIBFTLl78U
Yes, I have seen screenshots already, and will be trying some more things. I may send you a few messages asking you to check on your side, because as mentioned, it always works from here ...
Overmaster wrote:Crop bug: https://youtu.be/iQAe90K5KFI
Not sure I understand what is going on in the video, or what you are trying to do. Please can you add crop to a page, and then send me the link to that page where you applied crop, where it is not working?
http://green-frame.com/
Crop 2x1
 
User avatar
mjau-mjau
X3 Wizard
Topic Author
Posts: 11337
Joined: 30 Sep 2006, 07:37

Re: X3 Status Update [Aug 15]

19 Nov 2015, 14:37

Overmaster wrote:http://green-frame.com/
Crop 2x1
This is because you are using LARGE images in a WIDE VERTICAL layout, which also means it detects that it should load the originals. Try setting a NARROW gallery layout ... You can also see that the crop works nicely on smaller devices, or if you size your screen downwards (and refresh), because on smaller screens, it does NOT request the full-size image.

Although we may look into this later, it is not strictly a bug. Crop was meant for grid layouts, or styled layouts, not wide full-image layouts displaying full-size images. The reason for this, is because the calculated with of the image is likely 1280+ (or higher, especially on retina), which means the system will request the original. It will likely FAIL to crop images at 1600px width, because of server memory limits, and therefore, requests made to full-size images, always bypass the crop-mechanism.
 
Soundinhell
Posts: 23
Joined: 19 Nov 2015, 13:46

Re: X3 Status Update [Aug 15]

19 Nov 2015, 15:46

I have been following Imagevue for very long now and really want to work with the new version. What can I do to get a copy of x3? I have dedicated server and a theme on what to work. Can report bugs, problems and anything else needed to improve it.
 
User avatar
mjau-mjau
X3 Wizard
Topic Author
Posts: 11337
Joined: 30 Sep 2006, 07:37

Re: X3 Status Update [Aug 15]

19 Nov 2015, 15:53

Soundinhell wrote:I have been following Imagevue for very long now and really want to work with the new version. What can I do to get a copy of x3? I have dedicated server and a theme on what to work. Can report bugs, problems and anything else needed to improve it.
PM sent.
 
tschortsch
Experienced
Posts: 150
Joined: 01 Apr 2010, 21:23

Re: X3 Status Update [Aug 15]

20 Nov 2015, 10:28

mjau-mjau wrote:
tschortsch wrote:Is there a way to use the 3D text logo combined with an image logo or at least an image logo with simple text?
Although it could be possible, the default 3D effect only applies on vector-based text-layers. Not sure how it would look on an image even if it did work.
I was actually trying to ask for an option to place text next to the logo which can be styled separately for the startpage, e. g. if I use a logo composed of a graphic and white text, the color of the text naturally remains the same when navigating through the gallery. While the text looks great on the startpage (index page) set with an darker image as background it is hardly legible on all other sites where the background color is similar to text color..

Would this be possible solely using custom CSS magic?
 
User avatar
mjau-mjau
X3 Wizard
Topic Author
Posts: 11337
Joined: 30 Sep 2006, 07:37

Re: X3 Status Update [Aug 15]

20 Nov 2015, 10:41

New Update v0.12.12 Available!
Fixed a few critical bugs, and unless new ones emerge, this is a serious candidate for release. Usual download link applies, and you can get the smaller version without sample "content" folder at x3.latest.nocontent.zip.

0.12.12 Update Reference
- Fixed justified bug (thanks @Overlord).
- Fixed broken slidemenu layout.
- Fixed several bugs in styler.
- Added SVG support for uploader, especially for use with logo.
- Convert.php now excluded from release. Get it here instead (separate post coming shortly).

Update
As usual, copy all new files over, except content and config folders. That's it!

Updated Demo
https://demo.photo.gallery/