Search…

X3 Photo Gallery Support Forums

Search…
 
User avatar
fsfs
Experienced
Topic Author
Posts: 56
Joined: 24 Apr 2012, 11:28

Text, title bug

27 Feb 2015, 17:55

Hey Karl! I got another problem for your with second title and further on you create in content.
None of the matters where the titles puts in, whether it's the beginning or end. The first title doesn't affect, but the second+ does get too much space beneath.

Tried all text formation, nothing works. Check how big difference it is, you can see the red line.
text_bug.jpg
text_bug.jpg (230.24 KiB) Viewed 1374 times
 
User avatar
mjau-mjau
X3 Wizard
Posts: 11337
Joined: 30 Sep 2006, 07:37

Re: Text, title bug

28 Feb 2015, 15:31

Yes, this is a known bug since one of the last releases (perhaps the last) ... It is in some CSS header styles that are meant to set spacious margins, without affecting top header, but it is applying incorrectly for other headers also. I am looking to include this in a maintenance fix, but in the meantime, you can set inline style for the first header.

The bug is in fact with the "first" header, not the successive headers. You can try to add 3-4 headers, and you will see they are the same, except for the first one. It may seem like a lot of margin, but it is generally quite comfortable spacing between paragraphs in a scrolling environment.

I temporary fixed it on mjau-mjau.com, by setting first h2 header manually:
Code
<h2 style="margin-bottom: 0.8em;">Single Page Applications</h2>
See it here, with default spacings, which I think are ok:
https://mjau-mjau.com/blog/ajax-universal-analytics/