Search…

X3 Photo Gallery Support Forums

Search…
 
User avatar
masquefotos
Experienced
Topic Author
Posts: 140
Joined: 20 May 2011, 09:38

questions about beta 08-09

17 Feb 2015, 16:43

Hola Karl
Why before the beta 0.8 in PageSpeed I scored 81/100 and now with the beta 0.9 without changing anything new update just putting me down to 65/100?
Is it slower now?

Gracias
 
User avatar
mjau-mjau
X3 Wizard
Posts: 11337
Joined: 30 Sep 2006, 07:37

Re: questions about beta 08-09

18 Feb 2015, 02:04

Your performance score is being penalized for not serving compressed assets (css+json):
Image
I am not sure how this was working earlier but not any more ... I could check a few things if you have FTP for me.
Is it slower now?
It would certainly help if your server compressed those assets, but it is unlikely that it is slower than before. The page performance scores are only based on "best practices", and don't even rate the pure output performance. You still have plenty of performance benefits from latest version that don't sum in in google pagespeed.

In Pingdom, your site is rated 97%
Image

You would likely get a 99% score if the "vary" header was set, and this is related to the lack of compression on your website:
Image

Both the issues above could be automatically solved by using Cloudflare service, but it would be good to get things working perfectly on your server first, regardless.

Although the main issue in google pagespeed is lack of compression, you could also gain a few points by optimizing your logo.
Pagespeed wrote:Optimize images
Properly formatting and compressing images can save many bytes of data.
Optimize the following images to reduce their size by 18.9KiB (78% reduction).
Losslessly compressing http://www.jcarloscruz.com/content/cust ... lanca2.png could save 18.9KiB (78% reduction).
 
User avatar
masquefotos
Experienced
Topic Author
Posts: 140
Joined: 20 May 2011, 09:38

Re: questions about beta 08-09

18 Feb 2015, 05:55

Thanks for wasting time with me Karl
what has me a little confused is that prior to v0.8 do not penalize me for gzip and v0,9 if :shock: :shock:
What am I missing?
Thank you so much
 
User avatar
mjau-mjau
X3 Wizard
Posts: 11337
Joined: 30 Sep 2006, 07:37

Re: questions about beta 08-09

18 Feb 2015, 15:28

masquefotos wrote:what has me a little confused is that prior to v0.8 do not penalize me for gzip and v0,9 if :shock: :shock:
Well, I am not quite sure how/why gzip was working earlier but not now ... That is basically what your website is getting penalized for in terms of pure score. I would like to investigate, but that would require FTP ...
 
User avatar
mjau-mjau
X3 Wizard
Posts: 11337
Joined: 30 Sep 2006, 07:37

Re: questions about beta 08-09

19 Feb 2015, 05:28

Fixed!
Image

It seems your Apache server is a slightly older version without mod_filter, so it could not be used as a condition in the htaccess file to apply compression. I just removed the <IfModule mod_filter.c>, so this is not a problem.

From:
https://github.com/h5bp/html5-boilerpla ... /.htaccess
html-boilerplate-htaccess wrote: # Compress all output labeled with one of the following media types.
#
# (!) For Apache versions below version 2.3.7 you don't need to
# enable `mod_filter` and can remove the `<IfModule mod_filter.c>`
# and `</IfModule>` lines as `AddOutputFilterByType` is still in
# the core directives.
#
# https://httpd.apache.org/docs/current/m ... lterbytype
Now your CSS loads compressed at 33kb instead of 221kb. Big difference!
 
User avatar
masquefotos
Experienced
Topic Author
Posts: 140
Joined: 20 May 2011, 09:38

Re: questions about beta 08-09

19 Feb 2015, 08:59

Thank you very much Karl, should I keep this htaccess for upcoming updates?
 
User avatar
mjau-mjau
X3 Wizard
Posts: 11337
Joined: 30 Sep 2006, 07:37

Re: questions about beta 08-09

19 Feb 2015, 10:50

masquefotos wrote:Thank you very much Karl, should I keep this htaccess for upcoming updates?
That should be ok for the forthcoming future ... Unfortunately, it is hard for us to maintain a global htaccess file that suits all servers.
 
User avatar
nz-photo
Experienced
Posts: 244
Joined: 06 Dec 2007, 22:26

Re: questions about beta 08-09

19 Feb 2015, 20:01

I am exactly in the same case as you JC. So I'll try to check my apache version and what Karl does to accelerate it...

Edit:
Ok after modification (removing the 2 lines with <IfModule mod_filter.c> and </IfModule>
# (!) For Apache versions below version 2.3.7 you don't need to
# enable `mod_filter` and can remove the `<IfModule mod_filter.c>`
# and `</IfModule>` lines as `AddOutputFilterByType` is still in
# the core directives.
I'm now up to 87/100 again (58/100 for mobile...)
Empty your mind, be formless, be shapeless, like water...
www.nz-photo.com
 
User avatar
mjau-mjau
X3 Wizard
Posts: 11337
Joined: 30 Sep 2006, 07:37

Re: questions about beta 08-09

20 Feb 2015, 15:40

hmmm ... I might have to remove this conditional check then. Too bad its virtually impossible to maintain a htaccess file that suits all apache servers ...
 
Schorsch
Posts: 9
Joined: 20 Feb 2015, 22:35

Re: questions about beta 08-09

21 Feb 2015, 07:57

[The extension tiff has been deactivated and can no longer be displayed.]

Hello,
i changed the name ( via ftp ) of my x3 folder, now just this is shown on display! Do i have to change settings?
best regards!
Schorsch

This is how it should look!

http://www.georgsingerfotos.de/x3/
 
User avatar
mjau-mjau
X3 Wizard
Posts: 11337
Joined: 30 Sep 2006, 07:37

Re: questions about beta 08-09

21 Feb 2015, 14:31

Schorsch wrote:This is how it should look!
Sorry, the image attached is empty ... I checked your link, and I don't see any problems?
 
Schorsch
Posts: 9
Joined: 20 Feb 2015, 22:35

Re: questions about beta 08-09

21 Feb 2015, 15:12

Here you can see what the problem is:

http://www.georgsingerfotos.de/2015
 
User avatar
mjau-mjau
X3 Wizard
Posts: 11337
Joined: 30 Sep 2006, 07:37

Re: questions about beta 08-09

21 Feb 2015, 15:18

Schorsch wrote:Here you can see what the problem is:

http://www.georgsingerfotos.de/2015
I see the slideshow with menu, and when I scroll down, I see 4 gallery links. What is wrong?
Image
Image
 
Schorsch
Posts: 9
Joined: 20 Feb 2015, 22:35

Re: questions about beta 08-09

21 Feb 2015, 15:30

[The extension tiff has been deactivated and can no longer be displayed.]

In every Browser is just shown something like in the image is shown ( cache is empty, every browser new started ..)
 
Schorsch
Posts: 9
Joined: 20 Feb 2015, 22:35

Re: questions about beta 08-09

21 Feb 2015, 15:54

please empty cache and you will have the same problem i think..

thanks