Search…

X3 Photo Gallery Support Forums

Search…
 
User avatar
mjau-mjau
X3 Wizard
Topic Author
Posts: 11337
Joined: 30 Sep 2006, 07:37

X3 Beta V0.6

05 Dec 2014, 17:59

X3 Beta v0.6 Dec 06
Another foundational release, fixing many bugs (including 2 critical ones in the panel) and improving several core features. Hopefully we can start looking into more exciting features- and improvements after this release if all goes well ... For those of you who don't have any specific issues with server, mail or the panel, you could skip this update.

---
Those of you who already have the "secret link", can use the same link to download this latest release. To those who don't yet have the "secret link", send me a PM, and I will provide it.
---

Panel
Fixed unlimited recursive folders creation on copy/move.
Fixed bug where page.yml gets overwritten.

Check Page
- added mail() function test to /check/ page
- improved permissions testing, mod_rewrite testing and open_basedir.
- added X3 version number

Custom Javascript
- Added new custom/javascript/ section in panel to add counters and custom js . Use custom JS, load external JS, or even hook on to X3 JS events.

More
- improved mailer, including new settings.
- Fixed Internet Explorer 10 bug.
- fixed chat ID bug
- Improved custom/css/ section in panel. Now can load remote CSS also
- re-added pre-compressed *.jsgz *.cssgz assets for better server/load performance.
- Added minify for improved minification of custom css and JS
- Added error_reporting as option in settings, but disabled by default
- allow root website redirect with new settings.server.base_dir setting [forum]
- Removed unused css sourcemap (*.map) load
- Removed subjective www-redirect in htaccess (redirect from www to non-www), as it may crash with other rules you have. *This setting is generally recommended though, so that you don't have both www- and non-www versions of your website.
- removed setting site.base_url
- fixed 3D-logo scrollbar bug [forum]
- Fixed various CSS for typography and mega menu.

---

Updating
The same goes for this update as previous update: Upload and overwrite ALL files, EXCEPT the /content/ folder, which contains all your pages, content and settings. You may need to make a backup of your panel/config.php file also if you have set a login (which is likely).

PS! For those of you who had to add a rewriteBase rule to the htaccess file i root, keep in mind you will need to re-add it again after updating to the latest .htaccess file!

NB! In this release, there are a few non-critical changes to settings. Go to your panel settings page, and check that you have a segment structure that resembles the one from v0.6:
Code
# Various global settings [Advanced]
settings:
  pagenav: auto
  preload: false
  server:
    rewrite: # true|false [default=true]
    base_url: # domain.com
    reporting: # true|false [default=false]
  mail:
    to: # Default mail to send to.
    from: # Many hosts require a 'FROM' address when sending mail.
---

Files changed:
Code
modified:   .htaccess
modified:   default.htaccess
modified:   LICENSE
renamed:    README.imagevue.md -> README.x3.md
modified:   check/index.php
modified:   content/_shared.yml
modified:   content/custom/css/custom.css
new folder:   content/custom/javascript/*
new folder:   extensions/minify/*
modified:   extensions/twig.imagevue.inc.php
modified:   index.php
modified:   panel/ajax_manage_dir.php
modified:   panel/ajax_show_filemanager.php
modified:   panel/filemanager_core.php
modified:   panel/filemanager_css/x3.panel.css
modified:   panel/filemanager_user/ajax_manage_dir.php
modified:   panel/filemanager_user/ajax_show_filemanager.php
modified:   panel/filemanager_user/footer.php
modified:   panel/filemanager_user/jqueryFileTree.php
modified:   panel/filemanager_user_core.php
modified:   public/css/imagevue.skin.default.css
modified:   public/css/imagevue.skin.default.cssgz
modified:   public/css/imagevue.skin.orange.css
modified:   public/css/imagevue.skin.orange.cssgz
modified:   public/js/imagevue.min.js
modified:   public/js/imagevue.min.jsgz
modified:   robots.txt
modified:   templates/diagnostics.html
modified:   templates/json_feed.json
modified:   templates/mail.txt
modified:   templates/page.html
modified:   templates/page.json
modified:   templates/partials/footer.html
modified:   templates/partials/head.html
modified:   templates/partials/head.skin.html
modified:   templates/sitemap.xml
 
User avatar
alexhenes
Experienced
Posts: 568
Joined: 28 Sep 2006, 20:13

Re: X3 Beta V0.6

05 Dec 2014, 22:02

when installing new builds... is it ok to keep the _cache directory in tact or should we clear it out?

also...

my panel settings look different from what you posted above: Here is what they look like.

# Various global settings
settings:
pagenav: auto # Navigate between sibling pages: true|auto|false
preload: false # Only set to true AFTER you are finished editing!


and even more... I now have a tree structure when I pull up www.merelyafleshwound.com
Alex
https://www.merelyafleshwound.com
https://www.goldenbikeshop.com
 
esteban94
Posts: 10
Joined: 30 Aug 2011, 15:56

Re: X3 Beta V0.6

05 Dec 2014, 23:35

It is a disaster with the V0.6.
My x3/check is ok but when I load the site it looks like the V0.1...
Attachments
x3v06.png
x3v06.png (35.58 KiB) Viewed 5047 times
 
User avatar
alexhenes
Experienced
Posts: 568
Joined: 28 Sep 2006, 20:13

Re: X3 Beta V0.6

05 Dec 2014, 23:56

this is what I got as well... here is why... and what I did.

Instead of using the .htaccess file that shipped with v.06 I used my own. I did this because I had made changes to it. When I used the .htaccess file that shipped with v.06 everything worked. However I had to go back and make necessary changes... ie. using option #2.

I now have v0.6 up and running... but my panel settings dont look as Karl specified.

Karl...

I know there are larger issues to be solved at the point in the game... but... when it is time... it would be nice if the following files were moved to a place that is not related to the shipped software.

1. app/_cache
2. panel/config.php
3. public/img facicon.png
Alex
https://www.merelyafleshwound.com
https://www.goldenbikeshop.com
 
User avatar
mjau-mjau
X3 Wizard
Topic Author
Posts: 11337
Joined: 30 Sep 2006, 07:37

Re: X3 Beta V0.6

06 Dec 2014, 04:43

alexhenes wrote:when installing new builds... is it ok to keep the _cache directory in tact or should we clear it out?
Certainly no need to clear it manually, because what needs to be refreshed is already refreshed automatically by X3. After an update, it will likely create new templates- and pages, and likely "unlink" old ones. However, the your precious images-cache would likely not need any refreshing, so you should definitely try to keep it.
alexhenes wrote:my panel settings look different from what you posted above: Here is what they look like.

# Various global settings
settings:
pagenav: auto # Navigate between sibling pages: true|auto|false
preload: false # Only set to true AFTER you are finished editing!
Then you haven't copied over all files because the latest v0.6's content/_shared.yml file definitely has more a few more settings there than that ... I am not sure how you have set up your FTP to not overwrite certain files, or if you skipped this one manually ... If you are not copying over all files, that could explain other errors also ...
alexhenes wrote:and even more... I now have a tree structure when I pull up http://www.merelyafleshwound.com
What exactly did you do to fix it? I can see the htaccess file you have there now definitely looks near-identical to the 0.6 version, which is required to load the CSS in the latest release (unless rewrite=false). I do suspect that the new htaccess hadn't been copied over properly initially, or sometimes there is some small lag until your server starts using the new file ...
esteban94 wrote:Re: X3 Beta V0.6
It is a disaster with the V0.6.
My x3/check is ok but when I load the site it looks like the V0.1...
It seems your server requires the rewriteBase fix in the htaccess, and you had this added earlier. When you update, you need to re-apply this rule to the htaccess file, because we cannot add it by default because it is not only specific to your server, but also the folder where you added X3. You need to open root .htaccess, and set:
Code
rewriteBase /x3
I am not 100% sure this will fix the drama, but I hope so. If it still doesn't work properly, then it could be related to the new compressed JS/CSS files but I can't see why that would happen ... If it doesn't work after adding rewriteBase to .htaccess, try go to settings and set settings.server.rewrite: false.
alexhenes wrote:I know there are larger issues to be solved at the point in the game... but... when it is time... it would be nice if the following files were moved to a place that is not related to the shipped software.

1. app/_cache
2. panel/config.php
3. public/img facicon.png
Noted, although it is complicated because these folders definitely have to ship, and at some point they get updated too (config.php, _shared.yml ... which wasn't updated in your case).
 
User avatar
Bulletproof IT
Experienced
Posts: 134
Joined: 04 May 2013, 08:36

Re: X3 Beta V0.6

06 Dec 2014, 06:26

Absolutely Fabulous Karl.
:D

Really well done. I am very impressed with this.


Question
Is there a way to overlay the TItle/Description and other info (as per X2) when you have clicked on an image and it is in full page (not full screen) slideshow mode? (The page that has next/prev, 10/50, close and fullscreen buttons).
It would be great to be able to display more than just the image number.
Thank you!
» I Imagevue X3 «
 
User avatar
Bulletproof IT
Experienced
Posts: 134
Joined: 04 May 2013, 08:36

Re: X3 Beta V0.6

06 Dec 2014, 08:19

Geez, I'm struggling to get my head around this .htaccess file. I have never had problems with any other web application's htaccess file, but this has thrown me off...

Am I meant to uncomment the lines to enable mod_rewrite? Don't you have it enabled by default? (despite the first line? RewriteEngine on)


This section is confusing me.
Code
# ----------------------------------------------------------------------
# Imagevue X3
# ----------------------------------------------------------------------
This replaces "/" to "?" I gather? Is that all?
OR is it only replacing and removing the file type extension? e.g. PNG / JPG / JPEG....
or is it replacing all specific requests to a particular gallery only?
Code
# Rewrite gallery/img/solar_delight/ --> ?gallery/img/solar_delight_jpg
Can this be enabled? Is anything else required to be set-up or configured?
Code
# Redirect to compressed gz file if it exists
# RewriteCond %{REQUEST_FILENAME}gz -f
# RewriteRule ^(.+)\.(css|js)$ $1.$2gz [L]


The next section that I find confusing is:
Code
# ######################################################################
# # REWRITES                                                           #
# ######################################################################

# ----------------------------------------------------------------------
# | Rewrite engine                                                     |
# ----------------------------------------------------------------------
Options 1,2,3,4 and 5. They are all commented out by default.
1 = We already have "rewriteengine on" on the first line.

2 = Enable followsymlinks if it isn't already. You mean if it isn't enabled in the root of the domain or sub-domain? Or do you mean at the top of the htaccess file we're viewing?

4 = RewriteBase. This is already specified earlier and commented out. I don't believe it is good practice having it in there twice.


Sorry for the silly questions, I just don't want to be going around in circles when I could be helping elsewhere or being productive with work :D heheh
Thanks Karl!
» I Imagevue X3 «
 
User avatar
mjau-mjau
X3 Wizard
Topic Author
Posts: 11337
Joined: 30 Sep 2006, 07:37

Re: X3 Beta V0.6

06 Dec 2014, 08:24

Bulletproof IT wrote:Question
Is there a way to overlay the TItle/Description and other info (as per X2) when you have clicked on an image and it is in full page (not full screen) slideshow mode? (The page that has next/prev, 10/50, close and fullscreen buttons).
It would be great to be able to display more than just the image number.
Thank you!
It should already display the title, in bottom left corner ... Does this not work for you?
Image
We are already planning on adding a new different popup already for next release, because we have discovered a better fundament.
 
User avatar
mjau-mjau
X3 Wizard
Topic Author
Posts: 11337
Joined: 30 Sep 2006, 07:37

Re: X3 Beta V0.6

06 Dec 2014, 08:35

Bulletproof IT wrote:Geez, I'm struggling to get my head around this .htaccess file. I have never had problems with any other web application's htaccess file, but this has thrown me off...
Seems to me you are messing with settings that are commented out that are simply optional. Is it not working in its default mode?
Bulletproof IT wrote:Am I meant to uncomment the lines to enable mod_rewrite? Don't you have it enabled by default? (despite the first line? RewriteEngine on)
What lines do you want to uncomment? Mod rewrite works by default YES. However, some servers require rewriteBase to be set, and this you would know from your /check/ page. You don't normally have to touch the .htaccess file, so I assume you are doing it because your server requires the rewriteBase rule ...
Bulletproof IT wrote:This replaces "/" to "?" I gather? Is that all?
OR is it only replacing and removing the file type extension? e.g. PNG / JPG / JPEG....
or is it replacing all specific requests to a particular gallery only?
Code
# Rewrite gallery/img/solar_delight/ --> ?gallery/img/solar_delight_jpg
Why are you even considering modifying code that is DISABLED with the # comment tag in front? You are looking at code that is commented out, not doing anything, but remains as notes in the htaccess file because we were working on something. You don't need to change any of this, and even if you did, it would not change anything!
Bulletproof IT wrote:Can this be enabled? Is anything else required to be set-up or configured?
Code
# Redirect to compressed gz file if it exists
# RewriteCond %{REQUEST_FILENAME}gz -f
# RewriteRule ^(.+)\.(css|js)$ $1.$2gz [L]
It can, but it won't do anything ... Again, I am not sure why you are going through these things. htaccess is ready works out-of-the-box, and you may ONLY need to change rewriteBase because your server requires it (thus we cannot enable it by default for majority of servers that dont want it).
Bulletproof IT wrote:The next section that I find confusing is:
Code
# ######################################################################
# # REWRITES                                                           #
# ######################################################################

# ----------------------------------------------------------------------
# | Rewrite engine                                                     |
# ----------------------------------------------------------------------
Options 1,2,3,4 and 5. They are all commented out by default.
1 = We already have "rewriteengine on" on the first line.

2 = Enable followsymlinks if it isn't already. You mean if it isn't enabled in the root of the domain or sub-domain? Or do you mean at the top of the htaccess file we're viewing?

4 = RewriteBase. This is already specified earlier and commented out. I don't believe it is good practice having it in there twice.
Again, this entire section is commented out and does not serve you any purpose unless you know what it means and have special requirements for changing your server setup.
Bulletproof IT wrote:Sorry for the silly questions, I just don't want to be going around in circles when I could be helping elsewhere or being productive with work :D heheh
Thanks Karl!
No problems ... the htaccess is complicated, also for me ... but it is not a settings file or anything for you the user to edit. The only setting you may need to adjust is rewriteBase as mentioned, because some server require setting it, while most don't need it.
 
User avatar
Bulletproof IT
Experienced
Posts: 134
Joined: 04 May 2013, 08:36

Re: X3 Beta V0.6

06 Dec 2014, 09:50

Messing with settings? No no no no. Just trying to understand why variables are duplicated across the file.

No. ModRewrite is fine. Just looking at the file as it could be simplified and arranged better (no doubt down the track).

# = commented out. I.e. disabled and can be enabled. That's the whole point of #.
Oh! So these lines you have prefixed with # are "IN DEVELOPMENT AND NOT FUNCTIONAL" or "NOT FUNCTIONAL - IN DEVELOPEMENT"?


Yes I know what it means, but unsure why some of it is duplicated.
Karl I think you totally misunderstand what I am asking. It's so simple - "This section is not obvious. It shows examples, and does not say it is non-functional. Again I am going through the htaccess in more detail now, since 0.4 I just used "as-is". So again, I don't know why I wouldn't see what other options and settings are available... I assumed "if it is there, and doesn't say it is non-functional, I will try it out!"

If it is commented out and not serving any purpose, then you should say that. Currently it is not stated anywhere which sections of the htaccess are function or non-functional. I would add this before each section that is not currently functional:
Code
# ATTENTION! THE FOLLOWING SECTIONS ARE UNDER DEVELOPMENT AND NON-FUNCTIONAL!
Yes, thanks Karl. Like I said - no issue with default setup. I wanted to explore and try the other options available for rewriting URLs (e.g. without extensions).
Thanks!



Just some quick questions that require a yes or a no. Maybe a few word answer for a couple of them. But don't let me take up too much of your time.

QUESTION
I found this only allows two words (i.e. 1 space). You may want to update the comment: "# Default title / logo. Only supports two words."
Code
# Global site settings
site:
  title			: Flame Pix # Default title / logo.
QUESTION
The 'description: # Default description." value doesn't seem to be configured to do anything.

QUESTION
The web site title does not seem to be configured (Greeting Earthling). Where is this changed?
Is this not yet implemented?

QUESTION
Do you plan to make the site title change when entering a gallery, sub-gallery, sub-sub-gallery, contact page, content page, etc?
e.g. Site Prefix: Hello Earthling
Site Suffix: Fred Bloggs' Gallery
Example Page Title: Hello Earthling | Galleries > Holidays > 2014 > Bermuda Triangle | Fred Bloggs' Gallery
Note: the bread crumbs could even be reversed. "Bermuda Triangle < 2014 < Holidays" instead?

QUESTION
I cannot figure out how to set the system to use MySQL authentication (i.e. table in DB for users and permissions etc).
Has this been implemented yet? (see previous private message re: MySQL Database Authentication)

QUESTION
Please fix the install.
A) The first name + last name have been added as a suffix without any space. "X3 panel has been installed and an email has been sent to you!Fred Bloggs"
B) The spelling of "lastname" is "last name".

QUESTION
I noticed that whilst using flat file access to the system, the admin area showed a list of folders on the left and they were expanded and clickable. However when performing Database install and navigating to the Admin area to manage the galleries, there are only 4 folders on the left. None of which expand or collapse!
Unless it is a setting I have changed, but all I remember doing is playing with flat file, then executing /install/ path.
Ideas?

QUESTION
I cannot figure out how you have populated the "Example" galleries and sub-galleries.
Some have a dozen images, but when you click on the 2nd tab, switching from "Page" to "Gallery", there are no items.
Could you please tell me how it is referencing the files? Obviously uploading the images once is much better than uploading them 100 times for different Examples.

So I guess my question is, how is it linking to the /content/ files when nothing is mentioned under any of these Example Galleries?

Thank You Karl!

mjau-mjau wrote:Seems to me you are messing with settings that are commented out that are simply optional. Is it not working in its default mode?

Why are you even considering modifying code that is DISABLED with the # comment tag in front? You are looking at code that is commented out, not doing anything, but remains as notes in the htaccess file because we were working on something. You don't need to change any of this, and even if you did, it would not change anything!

It can, but it won't do anything ... Again, I am not sure why you are going through these things. htaccess is ready works out-of-the-box, and you may ONLY need to change rewriteBase because your server requires it (thus we cannot enable it by default for majority of servers that dont want it).

Again, this entire section is commented out and does not serve you any purpose unless you know what it means and have special requirements for changing your server setup.

No problems ... the htaccess is complicated, also for me ... but it is not a settings file or anything for you the user to edit. The only setting you may need to adjust is rewriteBase as mentioned, because some server require setting it, while most don't need it.
» I Imagevue X3 «
 
User avatar
mjau-mjau
X3 Wizard
Topic Author
Posts: 11337
Joined: 30 Sep 2006, 07:37

Re: X3 Beta V0.6

06 Dec 2014, 12:54

Regarding the .htaccess file, let me explain briefly about this. First of all, just like any of the PHP or JS files, it is not something average users should be opening at all. The only reason why this is necessary for some users to open, is because some servers require tweaking a setting just to "normalize" their server. If everything was up to us, we would be running X3 for everyone on our own server, and there wouldn't even be a htaccess file accessible to users. We would also not put it in the root if we didn't have to.

Furthermore, the vast amount of data you see in this file is basically created as a joint effort by experts in the field, and is part of the html5 htaccess boilerplate. 80-90% of the text is commented-out options and instructions about how some options work. We don't want to remove this stuff from the htaccess file, just like its not removed from the boilerplate file. The reason we need it in the first place is because we can't trust that peoples private hosting automatically have gzip compression for example, and much more ... This is basically a range og rules that should be on most servers by default ... Unfortunately they are not, and we cannot subjectively enable them at will either because they may in many cases crash with how your server is setup.

You are not supposed to understand the settings there (unless you are familiar with it), just like you are not supposed to understand core PHP and javascript files in X3. I am sure the file could be tidied up to suit viewers, but this is not a core focus or even necessary. We want to keep a resemblance to the html5 boilerplate because it is professional and contains the best suggestions for small server tweaks if you know what you are doing.
QUESTION
I found this only allows two words (i.e. 1 space). You may want to update the comment: "# Default title / logo. Only supports two words."
Code
# Global site settings
site:
  title			: Flame Pix # Default title / logo.
It allows as many words as you want, unless you want to use the "bonus" 3D logo, which is just something we included because it was requested. This is already clarified in the Logo documentation:
https://www.photo.gallery/x3docs/settings/logo/
QUESTION
The 'description: # Default description." value doesn't seem to be configured to do anything.
Are you talking about in global settings? It may become the default description meta tag in your pages if the description for a specific page is not populate. Furthermore, some 3rd party services (social sharing etc.) often request a "site description" ... (future)
QUESTION
The web site title does not seem to be configured (Greeting Earthling). Where is this changed?
Is this not yet implemented?
Are you talking about my example start page in the release version? It is definitely set on the 1.index page, either in the title, or in the content setting.
QUESTION
Do you plan to make the site title change when entering a gallery, sub-gallery, sub-sub-gallery, contact page, content page, etc?
e.g. Site Prefix: Hello Earthling
Site Suffix: Fred Bloggs' Gallery
Example Page Title: Hello Earthling | Galleries > Holidays > 2014 > Bermuda Triangle | Fred Bloggs' Gallery
Note: the bread crumbs could even be reversed. "Bermuda Triangle < 2014 < Holidays" instead?
What exactly do you mean "site title"? Both the important <title> tag, and also the displayed <h1>title both change when navigating between pages. As for "breadcrumbs", we don't want to add that to the title ... The <title> is for seo and sharing, and should be kept in focus for the page ... Besides, I don't know what browsers even display the <title> any more, but perhaps internet explorer?
QUESTION
I cannot figure out how to set the system to use MySQL authentication (i.e. table in DB for users and permissions etc).
Has this been implemented yet? (see previous private message re: MySQL Database Authentication)
Reading your question below before this one leads me to ask: So did you get it working or not? You dont see table structures or anything, you just create the table and thats it. This is documented quite well already:
https://www.photo.gallery/x3docs/setup/panel/
QUESTION
Please fix the install.
A) The first name + last name have been added as a suffix without any space. "X3 panel has been installed and an email has been sent to you!Fred Bloggs"
B) The spelling of "lastname" is "last name".

ok
QUESTION
I noticed that whilst using flat file access to the system, the admin area showed a list of folders on the left and they were expanded and clickable. However when performing Database install and navigating to the Admin area to manage the galleries, there are only 4 folders on the left. None of which expand or collapse!
Unless it is a setting I have changed, but all I remember doing is playing with flat file, then executing /install/ path.
Ideas?
Unless you have changed other thing in the config file or some other file, the database doesn't in any way dictate how the panel works except for the login itself. That is in fact the only difference in feature: user management.
QUESTION
I cannot figure out how you have populated the "Example" galleries and sub-galleries.
Some have a dozen images, but when you click on the 2nd tab, switching from "Page" to "Gallery", there are no items.
Could you please tell me how it is referencing the files? Obviously uploading the images once is much better than uploading them 100 times for different Examples.
Take a look at the assets: setting that can be used inside the folder: or gallery: setting. There are many examples in the page you see of how these things work ...
So I guess my question is, how is it linking to the /content/ files when nothing is mentioned under any of these Example Galleries?
When navigating the example pages, dont you see a range of settings with exactly how each page is configued?
Thank You Karl!
you are welcome!
 
User avatar
nz-photo
Experienced
Posts: 244
Joined: 06 Dec 2007, 22:26

Re: X3 Beta V0.6

06 Dec 2014, 13:41

I'm just like alexhenes after update to beta 0.6 when on my panel I still have in my settings tab :
Code
# Various global settings
settings:
  pagenav: auto # Navigate between sibling pages: true|auto|false
  preload: false # Only set to true AFTER you are finished editing!
Just like before... I uploaded everything but content folder AND I re-upload panel/config.php to retrieve my login and psw to the panel section...
:?: :?:
Empty your mind, be formless, be shapeless, like water...
www.nz-photo.com
 
User avatar
mjau-mjau
X3 Wizard
Topic Author
Posts: 11337
Joined: 30 Sep 2006, 07:37

Re: X3 Beta V0.6

06 Dec 2014, 13:49

nz-photo wrote:I'm just like alexhenes after update to beta 0.6 when on my panel I still have in my settings tab :
I am not quite sure why this is happening, but please open the file content/_shared.yml from the latest ZIP and compare it with the content/_shared.yml on your server ... Are they different? If so, then for some reason you are not copying over the new _shared.yml file ...

To be honest, maybe you shouldn't, and instead just copy the new settings in? This is unfortunately one hazard with the beta as stated in the beta docs ... The settings file with be changed and extended, and your FTP will not automatically "merge" new settings and keep your own settings at the same time.
 
User avatar
nz-photo
Experienced
Posts: 244
Joined: 06 Dec 2007, 22:26

Re: X3 Beta V0.6

06 Dec 2014, 13:59

OK !! So now I do know why : I didn't overwrite my content folders as you said in the intro :
Updating
The same goes for this update as previous update: Upload and overwrite ALL files, EXCEPT the /content/ folder, which contains all your pages, content and settings. You may need to make a backup of your panel/config.php file also if you have set a login (which is likely).
Nothing was specyfied about the _shared.yml inside content folder.
so mine, that contains all my details, hasn't been overwritten.
I have to overwrite it AND re-add all my website infos... Then it will change. :mrgreen:
Empty your mind, be formless, be shapeless, like water...
www.nz-photo.com
 
User avatar
mjau-mjau
X3 Wizard
Topic Author
Posts: 11337
Joined: 30 Sep 2006, 07:37

Re: X3 Beta V0.6

06 Dec 2014, 14:27

nz-photo wrote:OK !! So now I do know why : I didn't overwrite my content folders as you said in the intro :
Right. I guess my instructions were a bit vague, but that is why I noted about the update in settings ... basically you dont need these new settings, but you could just copy-paste that settings segment in this original post into your own settings ... thus not overwriting your own settings.

This is a challenge especially in the beta stage, because there is not really any simple way to solve it while new settings are being added ... I might come up with some bright ideas ...