Search…

X3 Photo Gallery Support Forums

Search…
 
User avatar
mjau-mjau
X3 Wizard
Topic Author
Posts: 11337
Joined: 30 Sep 2006, 07:37

Critical Issues > Pending Update v0.5

24 Nov 2014, 04:19

Since initial release, we have been diagnosing a lot of similar issues regarding to mod_rewrite and incorrect paths, basically preventing X3 from working on several hosts. After a lot of research, we are working on a new release which will hopefully fix- or patch most of these issues. For those of you who are awaiting a fix, please hold on for v0.5 to be released within Tuesday.

Pending Critical Fixes
Below is a list of issues we are working on based on initial diagnostics from dozens of beta installations:

For those who have been struggling with mod_rewrite, you may be able to fix the issue yourself:

Mod Rewrite
After struggling with this issue on a few hosts, we have discovered the cause. Some servers require a RewriteBase setting to be applied in the .htaccess file, which basically sets the base path of rewrite rules. If you are having problems with mod_rewrite ("white tree", assets not loading or pages not loading), then try to open the .htaccess file and comment out the rule: rewriteBase / (approximately line 29):
Code
# If you are running from a subdirectory, your rewritebase should match the name of the path to where X3 is stored.
# RewriteBase / # example1 - if running x3 in domain root, 
# RewriteBase /x3 # example2 - if running from a root folder named 'x3', 

RewriteBase /
Unfortunately, we can't set this by default, because it will break servers that have correct defaults, and also because the path depends on the subfolder path where you may have uploaded X3. We will instead try to create improved detection in the diagnostics page, and recommend this feature if it seems necessary.

Incorrect Paths
There has been a couple of servers serving incorrect paths and links when using X3 in a subfolder. We are still not entirely sure why the code fails, but we have been able to find a better implementation. This will be fixed in 0.5.

Critical Panel bug
We have an issue reported for the admin from two users, where a copy- or move action starts creating unlimited recursive folders. This is critical because it will create an incredibly deep unwanted folder branch, which will is so deep that it can break both the frontend and backend from running. Although this issue is server-related, you may wish to avoid move+copy actions until it is fixed.

Updated Docs
We have also uncovered the fact that most modern servers don't need chmod 777 permissions applied to folders that X3 needs to write to. Most servers that are configured correctly and have the same user-ID for _FTP and _WWW, don't need permissions set at all. In fact, setting chmod 777 on some servers will create a server error because of some security implementation. We need to add better documentation- and tests to check if permissions are required to be set, before you actually set them incorrectly ...

Next update should be out within Tuesday, and hopefully we can get these issues solved.
 
User avatar
nz-photo
Experienced
Posts: 244
Joined: 06 Dec 2007, 22:26

Re: Critical Issues > Pending Update v0.5

24 Nov 2014, 09:40

So is it better to set permissions to 755 rather than 777 on content folders and some admin ones ?
Empty your mind, be formless, be shapeless, like water...
www.nz-photo.com
 
User avatar
mjau-mjau
X3 Wizard
Topic Author
Posts: 11337
Joined: 30 Sep 2006, 07:37

Re: Critical Issues > Pending Update v0.5

24 Nov 2014, 14:06

nz-photo wrote:So is it better to set permissions to 755 rather than 777 on content folders and some admin ones ?
It depends on your server, but basically yes. If you can set 755 permissions, and you don't get any errors, great ... however, that also means that you shouldn't need to be concerned with permissions at all, because they should sufficient in their default state immediately after upload.
 
User avatar
alexhenes
Experienced
Posts: 568
Joined: 28 Sep 2006, 20:13

Re: Critical Issues > Pending Update v0.5

24 Nov 2014, 18:36

any chance the "Orphans" but will be fixed in V0.5 ?
Alex
https://www.merelyafleshwound.com
https://www.goldenbikeshop.com
 
User avatar
mjau-mjau
X3 Wizard
Topic Author
Posts: 11337
Joined: 30 Sep 2006, 07:37

Re: Critical Issues > Pending Update v0.5

24 Nov 2014, 18:49

alexhenes wrote:any chance the "Orphans" but will be fixed in V0.5 ?
You mean in justified gallery layout? No, I don't delay an update to add an unrelated update ... whereas I could instead launch two updates in the same timeline.

Justified "orphans" are off-topic for this release fixing critical path, mod_rewrite and server issues that has been creating havoc since initial release, and taking up our time ...
 
User avatar
alexhenes
Experienced
Posts: 568
Joined: 28 Sep 2006, 20:13

Re: Critical Issues > Pending Update v0.5

24 Nov 2014, 19:00

makes sense...

wasn't suggesting a delay in v0.5
Alex
https://www.merelyafleshwound.com
https://www.goldenbikeshop.com
 
ccris6
Posts: 5
Joined: 02 Dec 2013, 08:04

Re: Critical Issues > Pending Update v0.5

25 Nov 2014, 01:48

Hi Karl, i use a subdir to install X3 but I can't see anything.
In .htaccess I commented Option FollowSymlinks
and then also Option SymLinksIfOwnerMatch
because I've seen these errors in the error log on the server:

[Tue Nov 25 02:32:08 2014] [alert] [client 93.35.55.239:50343] - www.eral55.com - /web/htdocs/www.eral55.com/home/blog/.htaccess: Option FollowSymlinks not allowed here
[Tue Nov 25 02:25:38 2014] [alert] [client 93.35.55.239:50183] - www.eral55.com - /web/htdocs/www.eral55.com/home/blog/.htaccess: Option SymLinksIfOwnerMatch not allowed here

and followed all the install mod, but anything appear:

RewriteBase /blog

and

<IfModule mod_rewrite.c>

# (1)
RewriteEngine On

# (2)
# Options +FollowSymlinks

# (3)
# Options +SymLinksIfOwnerMatch

# (4)
RewriteBase /blog

# (5)
# RewriteOptions <options>

</IfModule>


My diag works...

http://www.eral55.com/blog/diag/

thanks a lot
 
User avatar
mjau-mjau
X3 Wizard
Topic Author
Posts: 11337
Joined: 30 Sep 2006, 07:37

Re: Critical Issues > Pending Update v0.5

25 Nov 2014, 04:41

ccris6 wrote:Hi Karl, i use a subdir to install X3 but I can't see anything.
First of all, you have a "redirect loop" in your index https://d.pr/i/TNZl ... Before we can even start to diagnose, you need to find out why that is happening. Your /diag/ page seems to indicate that it should work fine, although I am not sure if you added "rewritebase" there or not?

If you can offer FTP access, I can check for you.

Would be great if you could post in a separate thread though, as this is an announcement.
 
User avatar
masquefotos
Experienced
Posts: 140
Joined: 20 May 2011, 09:38

Re: Critical Issues > Pending Update v0.5

27 Nov 2014, 08:38

I want to try :(
 
User avatar
mjau-mjau
X3 Wizard
Topic Author
Posts: 11337
Joined: 30 Sep 2006, 07:37

Re: Critical Issues > Pending Update v0.5

28 Nov 2014, 08:15

masquefotos wrote:I want to try :(
viewtopic.php?f=51&t=8406&start=0